Cincinnerdi Tech Stuff

A mind-numbing read if ever there was one

Establishing a fault tolerant partial-mesh network using OSPF

with one comment


This was pretty cool. I could see that OSPF could converge after a line was disconnected in as little as 6 seconds and was able to re-establish the shorter path network path after reconnect in 49 seconds. Below you can see the extra hop and longer route trace route with the cable unplugged, then replugged. (This was from PC10 @ 172.16.1.34)
The debug entries will be listed below.I was able to setup a three-router partial-mesh net which had 6 separate LANs.

IP Stuff
All use the basic IP 172.16.1.x with a 255.255.255.248 (/29) subnet mask (0.0.0.7 wildcard mask). This allows for 6 hosts per network and 32 networks.

The networks between the 3 routers were .0, .8 and .16.

Testing the net setup
Using Angry IP scanner to scan the range .0 thru .45, I found 22 hosts. Hmm. This didn’t make sense. I have 9 IPs on the routers and 3 on the PCs. What are the other 10? The extras were .7 & .8, .15 & .16, etc. Ah! these are the broadcast and network IPs. Missing were .0 and ?. I think Angry purposelly skips .0. Not sure about the other.

Reset the password on a router using rommon and confreg
A router had a password set which was unknown. So I used the CCNA manual to remind me that you: 1) boot the router and press Ctrl-Break to get to the rommon prompt >. 2)Enter confreg and go thru a series of prompts. 3) Answer Y to the prompt, “Ignore system config info?” which changes 0x2102 to 0x2142. Yay!

Linux info
I used a Xubunutu Live CD as a 3rd workstation, mostly to ping other workstations. I setup a static IP using the GUI. Another student was trying to figure how to setup the same thing using the command line on Debian PC and found out how to setup a default gateway on the PC. Here’s what he found:

ip route add default via x.x.x.x
netstat -r

Where x.x.x.x is the IP of the gateway. Netstat is used to confirm.

Show Running-configuration from the 3550 switch
Building configuration…

Current configuration : 2924 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname l3sw1
!
enable secret 5 $1$gzQA$iy107wE1h9VVLIvAuXEdk1
enable password cisco
!
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport access vlan 4
switchport mode access
no ip address
…snip
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 172.16.1.33 255.255.255.248
!
interface Vlan3
ip address 172.16.1.18 255.255.255.248
!
interface Vlan4
ip address 172.16.1.10 255.255.255.248
!
router ospf 99
log-adjacency-changes
network 172.16.1.8 0.0.0.7 area 0
network 172.16.1.16 0.0.0.7 area 0
network 172.16.1.32 0.0.0.7 area 0
!
ip classless
ip http server
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
password exit
login
line vty 5 15
password exit
login
!
end

l3sw1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/29 is subnetted, 5 subnets
O 172.16.1.40 [110/2] via 172.16.1.17, 00:02:55, Vlan3
C 172.16.1.32 is directly connected, Vlan2
O 172.16.1.24 [110/2] via 172.16.1.9, 00:02:55, Vlan4
C 172.16.1.16 is directly connected, Vlan3
C 172.16.1.8 is directly connected, Vlan4
l3sw1#sho ip proto
Routing Protocol is “ospf 99”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 172.16.1.33
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.16.1.8 0.0.0.7 area 0
172.16.1.16 0.0.0.7 area 0
172.16.1.32 0.0.0.7 area 0
Routing Information Sources:
Gateway Distance Last Update
172.16.1.41 110 00:03:00
172.16.1.33 110 00:03:01
172.16.1.25 110 00:03:01
Distance: (default is 110)

l3sw1#sho cdp neighbors
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater, P – Phone

Device ID Local Intrfce Holdtme Capability Platform Port ID
rtr1 Fas 0/3 163 R S Cisco 1760Fas 1/1
rtr2 Fas 0/2 168 R S Cisco 1760Fas 1/1
l3sw1#debug ip ospf
Hello processing takes place every 10 seconds and consumes three lines of screen:
03:06:45: OSPF: Rcv hello from 172.16.1.41 area 0 from Vlan3 172.16.1.17
03:06:45: OSPF: End of hello processing

These have been stripped out of the following lines so we can just see the convergence processing. As debugging was started, the cable from fa 0/4 to rtr1 fa 1/1 was unplugged

03:06:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to down

03:06:52: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan4, changed state to down
03:06:52: OSPF: Interface Vlan4 going Down
03:06:52: OSPF: Neighbor change Event on interface Vlan4
03:06:52: OSPF: DR/BDR election on Vlan4
03:06:52: OSPF: Elect BDR 0.0.0.0
03:06:52: OSPF: Elect DR 172.16.1.25
03:06:52: OSPF: Elect BDR 0.0.0.0
03:06:52: OSPF: Elect DR 172.16.1.25
03:06:52: DR: 172.16.1.25
l3sw1# (Id) BDR: none
03:06:52: %OSPF-5-ADJCHG: Process 99, Nbr 172.16.1.25 on Vlan4 from FULL to DOWN, Neighbor Down: Interface down or detached
03:06:52: OSPF: Neighbor change Event on interface Vlan4
03:06:52: OSPF: DR/BDR election on Vlan4
03:06:52: OSPF: Elect BDR 0.0.0.0
03:06:52: OSPF: Elect DR 0.0.0.0
03:06:52: DR: none BDR: none
03:06:52: OSPF: Remember old DR 172.16.1.25 (id)
l3sw1#
03:06:53: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down
l3sw1#
03:07:03: OSPF: service_maxage: Trying to delete MAXAGE LSA
l3sw1#

The cable is reconnected here………………………
03:07:36: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
03:07:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
l3sw1#
03:08:05: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan4, changed state to up
03:08:05: OSPF: Interface Vlan4 going Up
l3sw1#
03:08:15: OSPF: Rcv hello from 172.16.1.41 area 0 from Vlan3 172.16.1.17
03:08:15: OSPF: End of hello processing
03:08:15: OSPF: Rcv hello from 172.16.1.25 area 0 from Vlan4 172.16.1.9
03:08:15: OSPF: 2 Way Communication to 172.16.1.25 on Vlan4, state 2WAY
03:08:15: OSPF: Backup seen Event before WAIT timer on Vlan4
03:08:15: OSPF: DR/BDR election on Vlan4
03:08:15: OSPF: Elect BDR 172.16.1.33
03:08:15: OSPF: Elect DR 172.16.1.25
03:08:15: OSPF: Elect BDR 172.16.1.33
03:08:15: OSPF: Elect DR 172.16.1.25
03:08:15: DR: 172.16.1.25 (Id) BDR: 172.16.1.33 (Id)
03:08:15: OSPF: Send DBD to 172.16.1.25 on Vlan4 seq 0x87D opt 0x42 flag 0x7 len 32
03:08:15: OSPF: End of hello processing
03:08:15: OSPF: Rcv DBD from 172.16.1.25 on Vlan4 seq 0x193A opt 0x52 flag 0x7 len 32 mtu 1500 state EXSTART
03:08:15: OSPF: First DBD and we are not SLAVE
l3sw1#
03:08:20: OSPF: Retransmitting DBD to 172.16.1.25 on Vlan4
03:08:20: OSPF: Up DBD Retransmit cnt to 1 for 172.16.1.25 on Vlan4
03:08:20: OSPF: Send DBD to 172.16.1.25 on Vlan4 seq 0x87D opt 0x42 flag 0x7 len 32
03:08:20: OSPF: Rcv DBD from 172.16.1.25 on Vlan4 seq 0x87D opt 0x52 flag 0x2 len 132 mtu 1500 state EXSTART
03:08:20: OSPF: NBR Negotiation Done. We are the MASTER
03:08:20: OSPF: Send DBD to 172.16.1.25 on Vlan4 seq 0x87E opt 0x42 flag 0x3 len 132
03:08:20: OSPF: Rcv DBD from 172.16.1.25
l3sw1#on Vlan4 seq 0x87E opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
03:08:20: OSPF: Send DBD to 172.16.1.25 on Vlan4 seq 0x87F opt 0x42 flag 0x1 len 32
03:08:20: OSPF: Rcv DBD from 172.16.1.25 on Vlan4 seq 0x87F opt 0x52 flag 0x0 len 32 mtu 1500 state EXCHANGE
03:08:20: OSPF: Exchange Done with 172.16.1.25 on Vlan4
03:08:20: OSPF: Synchronized with 172.16.1.25 on Vlan4, state FULL
03:08:20: %OSPF-5-ADJCHG: Process 99, Nbr 172.16.1.25 on Vlan4 from LOADING to FULL, Loading Done
l3sw1#
03:08:25: OSPF: Rcv hello from 172.16.1.41 area 0 from Vlan3 172.16.1.17
03:08:25: OSPF: End of hello processing
03:08:25: OSPF: Rcv hello from 172.16.1.25 area 0 from Vlan4 172.16.1.9
03:08:25: OSPF: Neighbor change Event on interface Vlan4
03:08:25: OSPF: DR/BDR election on Vlan4
03:08:25: OSPF: Elect BDR 172.16.1.33
03:08:25: OSPF: Elect DR 172.16.1.25
03:08:25: DR: 172.16.1.25 (Id) BDR: 172.16.1.33 (Id)
03:08:25: OSPF: End of hello processing
l3sw1#no debug ip ospf events
OSPF events debugging is off

Advertisements

Written by scottledyard

2007, February 24th at 1:58 pm

Posted in OSPF

One Response

Subscribe to comments with RSS.

  1. hi!! excellent site

    tavox

    Tavox

    2007, February 24th at 6:33 pm


Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: