Cincinnerdi Tech Stuff

A mind-numbing read if ever there was one

Cisco EtherChannel and dual links

leave a comment »


Last week I explored STP with a trio of switches connected in a ring. Ditto yesterday, but I added double cables between 4 ports of two of the switches and enabled a EtherChannel link. As with most labs, the core part was easy and I chewed through a lot of time trying to ping simply because I hadn’t issued a no shutdown on VLAN1!

Found a good recap of what I did with EtherChannel at this web site. He needs to point out that the cost goes from 12 up to 19 when he disconnects a line.
And at this site are some neat ideas for additional switching labs. PLUS a way to zap any vlans but VLAN1:

conf t
delete flash:vlan.dat

Anyway, here’s some documentation of what went on.
I reset up the three switches and use spanning-tree vlan 1 root primary on switch 2:
3550sw2#sho span

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 0011.5c43.d900
This bridge is the root
Hello Time 2 sec Max Age 12 sec Forward Delay 9 sec

Bridge ID Priority 24577 (priority 24576 sys-id-ext 1)
Address 0011.5c43.d900
Hello Time 2 sec Max Age 12 sec Forward Delay 9 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/2 Desg FWD 19 128.2 P2p
Fa0/12 Desg FWD 19 128.12 P2p
Fa0/13 Desg FWD 19 128.13 P2p
Fa0/24 Desg FWD 19 128.24 P2p

==========
When I setup load balancing to use the source mac, nothing appeared in the sho run. I changed it to destination mac and you can see this below.
The relevant portions of the show running-config are:
!
port-channel load-balance dst-mac
…(snip)
!
interface Port-channel1
switchport mode dynamic desirable
no ip address
…(snip)
!
interface FastEthernet0/12
switchport mode dynamic desirable
no ip address
channel-group 1 mode desirable non-silent
channel-protocol pagp
…(snip)
!
interface FastEthernet0/24
switchport mode dynamic desirable
no ip address
channel-group 1 mode desirable non-silent
channel-protocol pagp
!
==========
Show Spanning-tree now indicates only one interface, Po1
3550sw2#sho span

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 0011.5c43.d900
This bridge is the root
Hello Time 2 sec Max Age 12 sec Forward Delay 9 sec

Bridge ID Priority 24577 (priority 24576 sys-id-ext 1)
Address 0011.5c43.d900
Hello Time 2 sec Max Age 12 sec Forward Delay 9 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
—————- —- — ——— ——– ——————————–
Fa0/1 Desg FWD 19 128.1 P2p
Fa0/13 Desg FWD 19 128.13 P2p
Po1 Desg FWD 12 128.65 P2p

==========
3550sw2#sho etherchannel
Channel-group listing:
———————–
Group: 1
———-
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: PAgP

==========
3550sw2#sho etherchannel port-channel

Port-channel: Po1
————

Age of the Port-channel = 00d:00h:47m:19s
Logical slot/port = 1/0 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits
——+——+——+——————+———–
0 00 Fa0/12 Desirable-NonSl 0
0 00 Fa0/24 Desirable-NonSl 0

Time since last port bundled: 00d:00h:41m:31s Fa0/12
==========
I setup vlan 1 to be 1.1.1.1, 1.1.1.2, 1.1.1.3 on switches sw1, sw2, and sw3.
I was able to ping all switches and the PCs connected to sw2 and sw3 from each switch. The ARP tables look like this:
3550sw3#sho arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 1.1.1.1 0 0011.bbb9.57c0 ARPA Vlan1
Internet 1.1.1.3 – 0011.5c4b.4b00 ARPA Vlan1
Internet 1.1.1.2 0 0011.5c43.d900 ARPA Vlan1
Internet 1.1.1.11 0 0019.d108.585b ARPA Vlan1
Internet 1.1.1.10 0 0016.d407.2359 ARPA Vlan1

==========
Tried to switch to the standards base LACP (versus Cisco’s PagP) but only had time to disable:
3550sw2(config)#no port-channel load-balance

3550sw2(config)#int rang fa 0/12 , fa 0/24

3550sw2(config-if-range)#no channel-group 1 mode desirable non-silent

==========
The sho run for the sw3:

3550sw3#termainal length 0
3550sw3#sho run
Building configuration…

Current configuration : 2706 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3550sw3
!
!
ip subnet-zero
!
!
port-channel load-balance dst-mac
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
interface Port-channel1
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/1
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/2
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/3
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/4
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/5
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/6
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/7
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/8
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/9
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/10
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/11
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/12
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/13
switchport mode dynamic desirable
no ip address
channel-group 1 mode desirable non-silent
channel-protocol pagp
!
interface FastEthernet0/14
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/15
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/16
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/17
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/18
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/19
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/20
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/21
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/22
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/23
switchport mode dynamic desirable
no ip address
!
interface FastEthernet0/24
switchport mode dynamic desirable
no ip address
channel-group 1 mode desirable non-silent
channel-protocol pagp
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
no ip address
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
no ip address
!
interface Vlan1
ip address 1.1.1.3 255.0.0.0
!
ip default-gateway 1.1.1.2
ip classless
ip http server
!
!
!
line con 0
logging synchronous
line vty 0 4
login
line vty 5 15
login
!
end

Advertisements

Written by scottledyard

2007, March 11th at 2:48 pm

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: